Added makefile to install Fluentd plugin.
authorStanislaw Klekot <dozzie@jarowit.net>
Wed, 10 May 2017 20:48:04 +0000 (22:48 +0200)
committerStanislaw Klekot <dozzie@jarowit.net>
Wed, 10 May 2017 20:48:04 +0000 (22:48 +0200)
fluentd/.gitignore [new file with mode: 0644]
fluentd/Makefile [new file with mode: 0644]

diff --git a/fluentd/.gitignore b/fluentd/.gitignore
new file mode 100644 (file)
index 0000000..c111b33
--- /dev/null
@@ -0,0 +1 @@
+*.gem
diff --git a/fluentd/Makefile b/fluentd/Makefile
new file mode 100644 (file)
index 0000000..57422e5
--- /dev/null
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+GEM = /usr/bin/gem1.9.1
+INSTALL_ROOT = /usr/lib/brookengine
+
+.PHONY: all
+all: fluent-plugin-brookengine.gem
+
+fluent-plugin-brookengine.gem: fluent-plugin-brookengine.gemspec
+       $(GEM) build $<
+       mv fluent-plugin-brookengine-*.gem $@
+
+.PHONY: install
+install: fluent-plugin-brookengine.gem
+       GEM_HOME=$(DESTDIR)$(INSTALL_ROOT)/fluentd $(GEM) install --local $<
+
+.PHONY: clean
+clean:
+       rm -f *.gem